Datalooper MK1 stopped working after i tried to update the firmware. need help.

Home Forums Datalooper Pedal Forum Datalooper MK1 stopped working after i tried to update the firmware. need help.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #361

    I just tried to update my Datalooper MK1 to the latest firmware 3.0 and now it stopped working, no lights, and not recognized by the computer anymore.

    I did the following:
    – Opened the updater in the latest package
    – hit Upload
    – the updater stopped uploading after 1/5 was done and responded with a red cryptic textstring on the bottom row of the updater. (Datalooper was still recognized though)
    – hit the upload button again -> same thing.
    – then closed the updater and disconnected the datalooper.
    – reconnected it to the computer and that’s where it stopped working. No lights. And no recognition by the computer anymore.

    Tried several USB Cables, still the same….

    What happened? Is the pedal broken? Or is it just a software Problem. How can I fix this.

    I really hope you can help me…


    Exactly the same issue as me. Every bullet point.

    I’ll keep checking this post. Vince, let us know if you need us to trouble shoot anything.


    Hey Ryan,

    Vince answered my mail and gave me the following advice:

    It sounds like you will need to do a hardware reset. To do that, open up the pedal, and then on the back of the PCB, you will see two angled contact points that need to be shorted (connected with a paperclip or something similar) while the USB cable is connected. That should then flash the DataLooper back to an initial firmware. You can then try reflashing the firmware onto the pedal. Make sure you’re directly connected to the computer when updating the firmware. Things should still work with rev-1.

    on my PCB the string „PGM1“ indicates these contact points. So i did it this morning and it worked. 🙂

    i assume it will work with your pedal also since it’s just a software problem.

    best of luck.


    Got mine working as well, which is a Rev-2. If anyone else stumbles on this:

    For Rev-2 there is a button on the PCB to do a hardware reset. Press it with the USB plugged in.
    Then flash the latest firmware.
    Then use the datalooper config to upload the default config. It needs to be a Chrome/Chromium browser. (I forgot that last part, it had been so long since I used it)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Shopping cart0
There are no products in the cart!
Continue shopping